最近的一点工作 20160627

How to Upgrade Git version >= 1.7.10 on CentOS 6

在centos上要装node,所以要装nvm,结果告诉我git版本不够,就查如何update git
需要root用户,http://tecadmin.net/how-to-upgrade-git-version-1-7-10-on-centos-6/

按照这个步骤走就可以。
file /sbin/init 或者 file /bin/ls 可以看64位或者32位。之后按照那篇的博客步骤走就好了。

Step 1: Install rpmforge Repository
Download and install rpmforge repository rpm using following commands.

RHEL/CentOS 6 - 64bit
# rpm -i 'http://pkgs.repoforge.org/rpmforge-release/rpmforge-release-0.5.3-1.el6.rf.x86_64.rpm'
# rpm --import http://apt.sw.be/RPM-GPG-KEY.dag.txt

RHEL/CentOS 6 - 32bit
# rpm -i 'http://pkgs.repoforge.org/rpmforge-release/rpmforge-release-0.5.3-1.el6.rf.i686.rpm'
# rpm --import http://apt.sw.be/RPM-GPG-KEY.dag.txt

Step 2: Edit rpmforge Yum Repository File

Edit your rpmforge repository file and change enabled=1 from 0 in [rpmforge-extras] section.

# vim /etc/yum.repos.d/rpmforge.repo

Step 3: Upgrade git Version

Upgrade git version on your system using following command and check the upgraded version.

# yum update git

then u can Check git version git –version

Step 4: Finally disable rpmforge-extras Repo

Edit and disable rpmforge-extras repository in rpmforge.repo and clean the yum data.

# yum clean all

highcharts 去掉右下角Logo

exporting:{
enabled:false
},
credits: {
enabled: false
},

遇到一个react的报错“was passed a style object that has previously been mutated”
其实是style中包含对象,对象是引用值,所以要用不可变对象,或者你直接复制一个新的object,将之前的object deep clone 过来就解决报错了。

使用公司git突然报错,过去没见过

The file will have its original line endings in your working directory. warning: LF will be replaced by CRLF

后来上网搜了下
http://stackoverflow.com/questions/13148066/warning-push-default-is-unset-its-implicit-value-is-changing-in-git-2-0/13148313
http://www.oschina.net/question/59932_33853

解决方法
git config –global core.autocrlf false

push的时候配置一下,一般simple模式就好。
git config –global push.default simple。

发表评论

电子邮件地址不会被公开。 必填项已用*标注